lede路由器番茄配置文件

root@OpenWrt:/etc/config# cat chinadns

1
2
3
4
5
6
7
config chinadns
option chnroute '/etc/chinadns_chnroute.txt'
option addr '0.0.0.0'
option enable '1'
option server '223.5.5.5,127.0.0.1#5300'
option bidirectional '1'
option port '5252'

root@OpenWrt:/etc/config# cat dns-forwarder

1
2
3
4
5
config dns-forwarder
option listen_addr '0.0.0.0'
option listen_port '5300'
option dns_servers '8.8.8.8'
option enable '1'

root@OpenWrt:/etc/config# cat dhcp

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option nonwildcard '1'
option localservice '1'
option noresolv '1'
list server '127.0.0.1#5252'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

root@OpenWrt:/etc/config# cat shadowsocks

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
config general
option startup_delay '10'

config transparent_proxy
option local_port '1234'
option udp_relay_server 'cfg054a8f'
option mtu '1500'
list main_server 'cfg054a8f'

config socks5_proxy
list server 'nil'
option local_port '1080'
option mtu '1500'

config port_forward
list server 'nil'
option local_port '5300'
option destination '8.8.4.4:53'
option mtu '1500'

config servers
option timeout '60'
option alias 'SSR'
option fast_open '1'
option no_delay '1'
option server '帐号IP'
option server_port '帐号端口'
option password '帐号密码'
option encrypt_method '帐号加密方式'

config access_control
option self_proxy '1'
option wan_bp_list '/etc/chinadns_chnroute.txt'
list wan_fw_ips '8.8.8.8'
list wan_fw_ips '8.8.4.4'
option lan_target 'SS_SPEC_WAN_AC'

config lan_hosts
option enable '1'
option host '192.168.4.242'
option type 'b'

config lan_hosts
option enable '1'
option host '192.168.4.112'
option type 'n'

root@OpenWrt:/etc/config# cat network

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd1a:0e5c:8eda::/48'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.4.1'
option netmask '255.255.255.0'
option ip6assign '60'
option ifname 'eth0.1 radio2 radio0'

config device 'lan_dev'
option name 'eth0.1'
option macaddr '2c:30:33:23:70:41'

config device 'wan_dev'
option name 'eth0.2'
option macaddr '2c:30:33:23:70:40'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 6t'
option vid '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'
option vid '2'

config switch_vlan
option device 'switch0'
option vlan '3'
option vid '3'
option ports '3 6t'

config interface 'wan1'
option proto 'dhcp'
option ifname 'eth0.2'
option metric '1'
option peerdns '0'
option dns '127.0.0.1'
option macaddr '2C:30:33:23:70:41'

config interface 'wan2'
option proto 'dhcp'
option ifname 'eth0.3'
option metric '2'
option peerdns '0'
option dns '127.0.0.1'
坚持原创技术分享,您的支持将鼓励我继续创作!